
BROCK UNIVERSITY MAP, DATA & GIS LIBRARY 

Intro to ArcGIS Pro 
 

What is “GIS”? 

Geographic Information Systems (GIS) is a tool used to display, create, and analyze spatial information to help solve 

real world problems. It combines the graphics that make up a map with data tables of associated attributes. Based 

on a fictitious case of Starbucks Corporation wishing to open a new coffee shop in St. Catharines, we will use GIS 

functionality to identify target areas. Download tutorial data at https://github.com/brockmdgl/Intro2Pro 

Section 1: Introducing ArcGIS Pro 

Before you begin, you must have an Esri account. Email maplib@brocku.ca to request an organizational account 

and ArcGIS Pro access. 

1. Run ArcGIS PRO. HINT: Click the Windows button then start typing ArcGIS 

2. When prompted, login using your ArcGIS Online credentials. 

3. Under Create a new project, click Blank.  

4. At the prompt, enter a name for the project (i.e. NewCoffeeShop) and a folder in which to store the project file 

and all associated files. Each project (.aprx) includes the associated toolboxes, databases, folder connections, 

styles and more. 

5. Click OK. 

The ArcGISPro interface is made up of ribbons, tabs, groups, panels, panes and window views (map). 
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6. ArcGIS Pro is very intuitive and adjusts depending on the layer that is active or the last tool used. 

7. From the View tab, click Catalog Pane. 

8. From the Catalog window on the right, expand Databases and notice the new geodatabase created for this 

project. All geoprocessing results will automatically be created in this geodatabase. 

9. To make a shortcut to the folder holding the tutorial data, right-click Folders > Connect and navigate to the 

location that the zipped tutorial data was extracted to. 

Creating a map and adding data 

1. Click the Insert tab at the top of the window and click New Map. The map window is automatically populated 

with an Esri basemap to give context to your mapping project. To select a different basemap, go to the Map tab 

and click Basemap. 

2. To find a location, click the Map tab then click Locate . Enter a city or other location and select the 

appropriate result from the list. For example, enter St. Catharines, Ontario and zoom to Niagara. 

3. Close the Locate tool by clicking the X in the upper right corner of the pane. Be sure to click the X for the tool 

pane, not the software! 

4. To apply a more localized projection, double-click on Map under Drawing Order in the Contents pane. 

5. Click Coordinate Systems and enter UTM in the search box. Navigate to Projected Coordinate System > UTM > 

NAD 1983 >   

6. Click OK to apply the new projection. 

7. From the Layer group at the top of the window, click Add Data  Browse to 

\Intro2ArcGISPro\StCatharines_Coffee_Shops.csv The table is added in the Contents pane listing to the left of 

the map window under the heading Standalone Tables. Right click the table and click Open. 

 

This table includes Tim Hortons and Starbucks restaurants located in St. Catharines, Ontario. We want to see this 

data on the map. Geocoding is the process of comparing addresses to known points on the map and creating 

geographic features to represent each record. Follow the steps below to create points for each coffee shop. 

8. Close the attribute table by clicking the X next to the table name. 

9. Right-click the standalone table in the Contents pane and click Geocode Table. The geoprocessing window is 

activated with the Geocode Addresses tool. Click Start at the bottom of the pane. 

10. Select More than one field (the default) and click Next. 

11. From the dropdown list for Input Address Locator, select ArcGIS World Geocoding Service. Click Next.  

12. The Input Address Fields are automatically populated. Click Next. 

13. To change the output feature class name, click the browse button and enter the name coffee_shops.  
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14. Click Save then Next. 

15. Select Canada from the country list and click Next. 

16. Accept the default Category and click Finish then Run. The process may take a few minutes. You will be 

prompted when the tool has finished.  

17. The map is automatically zoomed to the extent of the features. 

 

The Connection between attributes and features 

1. Right-click the new layer “coffee_shops” from the contents panel and click Attribute Table. A number of fields 

are added to the table but if you scroll across you will see the details of the coffee shops as seen earlier in the 

standalone table. 

2. Click the small gray square to the left of a record. The row is highlighted as well as the point on the map 

associated with the record. Click the zoom to  tool to find the feature on the map.  

3. Click Explore  to use your mouse scroll and left click to change the view extent, zoom level and pan.   

4. From the Selection group at the top of the window, click Select then click a different point on the map. The first 

point is deselected as well as the record in the attribute table. 

5. To see the newly selected attribute record, click Show Selected Records  at the bottom of 

the table window. 

6. Click Show All Records   

7. Click Clear (top of table window) to remove all selections. 

8. Click the Explore tool to activate it.  

9. Right-click the geocoded layer and click Zoom to Layer  

10. Close the attribute window before continuing. 

11. SAVE your map! HINT: click the save button.  
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Adding Data from ArcGIS Online 

ArcGIS Online is considered a portal for GIS data and resources. We will add 

some prepared data to enhance our study of site suitability for a new 

Starbucks. 

1. Activate the Catalog panel (bottom right set of tabs). 

2. Click the Portal option at the top and click All Portal . 

3. Enter the Search term  Niagara Census. From the listing, click and drag 

the layer “Niagara_Median_Household_Income” to the map. The layer 

may take a few seconds to load. This layer gives us a visual of the areas of 

St. Catharines that have high income.  

4. Click the Appearance tab and adjust the transparency slider  

5. Enter the search term ‘coffeedrinkers’ to find a layer created for this exercise depicting fictitious data about the 

population of coffee drinkers in St. Catharines. 

 

Symbology 

Symbols are used to represent features on a map. We will import a predefined set of symbols for the coffee shops 

then change the way in which the coffee drinkers are visualized. 

1. Click the coffee shops layer in the Contents panel to activate it. 

2. From the tabs at the top of the window, click Appearance then Import from the Drawing group. The tool is 

activated in the panel to the right of the map view. 

3. The input layer should be “coffee_shops” (or whatever name you gave the geocoded layer). 

4. For Symbology Layer, browse to the layer file in \Intro2ArcGISPro\coffeeshopstcatharines.lyrx 

NOTE: A layer file tells the software how to symbolize a specific data layer. 

5. Click OK. 

6. Accept the rest of the defaults and click Run. 
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The coffee drinkers’ data dominates the map. Point data has a variety of visualization options. We’ll use a heat map 

to highlight areas of the city where there is a concentration of coffee drinkers. 

7. Click the coffeedrinkers layer to activate it. 

8. Click the Appearance tab at the top and click Symbology > Heat map. This method of visualization really 

illustrates the hot spots in the city for coffee drinkers! 

9. From the Effects group at the top, shift the slider over to change the transparency of the layer. 

 

10. Click and drag the coffee shops layer up in the Contents panel so they draw over top of the other layers. 

11. Save your map! 

 

 

 

A quick study of the map shows a concentration of coffee drinkers in the downtown core as well as Port Dalhousie. 

The median average income is higher in Port Dalhousie than in the downtown area.  

Query  

We want to isolate the locations of Starbucks in the city and will perform a basic query function to accomplish this 

task. 

1. Select the coffee shops layer to activate it. 

2. From the Map ribbon click Select by Attributes;  

3. Click Add Clause: Name is equal to STARBUCKS; click Add. 

Port Dalhousie 

Downtown 
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4. Click Run to apply the specified query. Only the starbucks locations are highlighted on the map. 

5. Right-click the coffee shops layer > Selection > Make layer from selected features. 

6. Rename the layer to “Starbucks”. HINT: slowly click the layer name twice to activate renaming. 

7. Turn off original coffee shops layer. 

8. To adjust the symbology, click the selection layer in Contents then click Appearance > Symbology 

9. Right-click the symbol entry for Tim Hortons and click Remove. 

 

Buffer 

Our next task is to create a general service area buffer considering the distance consumers will travel for a cup of 

Joe. 

1. Select the new Starbucks layer in the Contents panel to activate it. 

2. Click the Analysis ribbon and then click Tools. The GeoProcessing pane opens to the right of the map view. Enter 

the search term “buffer” and select the Buffer result to activate the tool dialogue box. 

a. Input Features: Starbucks 

b. Output Feature Class: rename default to “Starbucks_buffer_2km” 

c. Enter a distance of 2 kilometres. 

 

d. Click Run. A new polygon layer is added to the Contents list. 
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Adding Neighbourhoods and labelling 

Our final task is to add a boundary file for neighbourhoods and label it. 

1. Click the Map ribbon and click Add Data. 

2. Click on Project > Folders > Intro2ArcGISPro > StCneighbhourhoods.shp and click OK. 

3. Change the symbology (click the symbol, select the second symbol option) 

4. Right-click layer and select Label. 

5. Click Labeling ribbon and select Label Placement > Basic Polygon. 

Further study of population density, land use or labour force statistics might help us understand the city better. 

However, for the purposes of this exercise we have identified these 2 sites as potential locations for a new Starbucks 

in St. Catharines. We will prepare a map layout to share with our colleagues. 

 

Creating a Layout and Sharing 

Let’s clean up the Contents panel.  

1. Slowly click twice on the coffeedrinkers layer name and rename it Coffee Drinkers.  

2. Rename the other layers as you see fit. 

3. Click the Insert tab and select New Layout. 

4. Select ANSI Landscape Letter. A new blank layout is added to the project views. 

5. Click the dropdown arrow beside Map Frame   and select the second option Map 1:52,… a map window 

is added to the Layout.  

6. Click and drag the window to reposition it.  

7. Click and drag a corner handle to resize the map. Leave room for other layout elements such as the legend. 

8. To change the zoom level of the map, right click the map and select Activate. When the map element is active 

you can use the Explore tool and other zoom and pan tools to customize the display.  

9. When you are finished, click Layout ribbon at the top of the display and click . 

10. From the Insert ribbon in the Map Surrounds group, add a North Arrow and Scale bar. Reposition and resize the 

elements as you see fit. 

11. From the Map Surrounds group, click Legend then draw a box on the map where you want the legend to sit.  

12. Double-click the legend to activate the Format Legend panel to the right of the Layout view. Options are also 

available in the Contents panel to the left (turn layers off if you don’t want them to appear in the Legend). 

13. Click the Text tool  to add customized text including a title and source statement. Explore the text 

options on the Format ribbon. 

14. Save your map! 
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Our map is complete and ready to share! 

15. Click the Share ribbon at the top of the window. To make a PDF or JPEG, click Layout 

16. Change the Save As type to the format of choice and navigate to your storage space on X:\ drive. 

17. Click Export. 

 

Additional Resources: 

 Going Pro: ArcGIS Pro Essentials for ArcMap Users (1 hour training video) 

https://www.esri.com/training/catalog/590901ecdb250232197d2326/going-pro%3A-arcgis-pro-essentials-

for-arcmap-users/  

 Getting Started with ArcGIS Pro (5 hours, web course) 

https://www.esri.com/training/catalog/57630435851d31e02a43f007/getting-started-with-arcgis-pro/  

 ArcGIS Pro Help http://pro.arcgis.com/en/pro-app/help/main/welcome-to-the-arcgis-pro-app-help.htm  

 

 

https://www.esri.com/training/catalog/590901ecdb250232197d2326/going-pro%3A-arcgis-pro-essentials-for-arcmap-users/
https://www.esri.com/training/catalog/590901ecdb250232197d2326/going-pro%3A-arcgis-pro-essentials-for-arcmap-users/
https://www.esri.com/training/catalog/57630435851d31e02a43f007/getting-started-with-arcgis-pro/
http://pro.arcgis.com/en/pro-app/help/main/welcome-to-the-arcgis-pro-app-help.htm

