Important Information regarding the "Heartbleed" Security Vulnerability

News around Campus

Important Information regarding the "Heartbleed" Security Vulnerability

Published on April 11 2014


Earlier this week, an internet security flaw known as “Heartbleed” was identified and featured on the news as well as various security sites. The Heartbleed security flaw is present in one of the most common security protocols (OpenSSL) used on the internet. This flaw makes sensitive information vulnerable to exposure or theft.

Brock ITS has already contacted our system vendors to determine if we are at all affected, and we are giving this vulnerability our highest attention and at this time, we do not have any evidence that a breach has occurred.

Also keep in mind that phishing attacks frequently occur when vulnerabilities such as this one are discovered and we would like to remind our users NOT to follow ANY links that are pasted in e-mails to change your passwords. Brock ITS recommends going directly to the my.brocku.ca portal to change their Brock passwords, and directly to the various organizational websites outside of Brock University to change those passwords.

If you have any questions of further concerns, please contact the ITS HelpDesk at ext. 4357.